Cybersecurity

Critical Vulnerability in GiveWP Plugin Enables Command Execution on WordPress Servers

The CVE-2026-82222 vulnerability in the GiveWP plugin allows attackers to execute arbitrary commands on a WordPress server and may affect versions up to 4.16.7.1. GiveWP released version 4.16.7.2 to address the flaw and delete serialized object payloads stored in affected databases.

2026-08-28
3 min read
186 views
certi.news Editorial Team
Critical Vulnerability in GiveWP Plugin Enables Command Execution on WordPress Servers

The GiveWP plugin for donations and fundraising campaign management has fixed a vulnerability with the highest severity rating that can be exploited to execute arbitrary commands on a WordPress server. The vulnerability is identified as CVE-2026-82222 and affects GiveWP versions up to 4.16.7.1, while version 4.16.7.2 was released to fix it on August 27, 2026.

The plugin is used on more than 100,000 websites, making the flaw significant for administrators of sites that rely on it to receive donations. According to details reported by Patchstack researchers, security researcher Udin Chan reported the vulnerability on July 28 through the Patchstack vulnerability intelligence platform.

A Chain of Three Issues

The exploitation process does not rely on a single flaw, but combines three interconnected weaknesses: an unsafe PHP deserialization mechanism, a donation-processing path that stores attacker-controlled serialized objects, and a gadget chain in libraries bundled with the plugin that can invoke system commands.

In its basic stage, the attack requires an account on the site, but Patchstack explained that an exposed and undocumented registration procedure allows an account to be created even when registration is disabled in WordPress settings. The attacker uses the account and its profile to store a malicious serialized object, then injects it into the plugin’s session database by submitting a specially crafted donation.

After that, requesting any front-end page using the authentication cookie causes the object to be deserialized and the command specified by the attacker to be executed. Patchstack security researcher George Johnstone said that the server writes the serialized object to the wp_give_sessions table before returning an HTTP 500 response.

When Are the Affected Versions Exploitable?

Versions 4.16.6 through 4.16.7.1 remain vulnerable, but exploitation requires an old donation form that lacks formBuilderSettings. This condition may appear on sites that have been upgraded, that use the options-based form editor, or that have imported or restored old forms.

What Changes in Practice?

Version 4.16.7.2 addresses the flaw by blocking serialized data during donation processing and restricting object creation at several deserialization points. The update also removes previously stored serialized object payloads from the databases of affected sites, an important step because the update is not limited to preventing new exploits.

However, Patchstack noted that the GiveWP registration procedure still does not respect WordPress settings governing whether users may register, although this behavior is no longer exploitable for code execution after the fix. Site administrators should therefore update the plugin to version 4.16.7.2 as soon as possible, while reviewing the presence of old donation forms or signs of account creation and unusual activity.

The flaw is also significant in light of GiveWP being targeted during the previous year, when attackers indirectly used the plugin to compromise Pi-hole, exposing the names and email addresses of 30,000 donors. The source does not establish that the previous exploitation campaign was directly connected to CVE-2026-82222, but it shows that donation plugins may provide an entry point whose impact extends beyond the compromised site itself.

News source
BleepingComputer
Open original source ↗
c
Author

certi.news Editorial Team

What you need to know

The GiveWP plugin contains a critical vulnerability, CVE-2026-82222, that could allow arbitrary command execution on a WordPress server under certain conditions. GiveWP released version 4.16.7.2 to fix the flaw. Site administrators should update, review older forms, and check for unusual activity.

  • The vulnerability affects GiveWP versions through 4.16.7.1, with versions 4.16.6 through 4.16.7.1 remaining exploitable when additional conditions are met.
  • The exploit chains insecure PHP deserialization, attacker-controlled object storage, and a gadget chain capable of invoking system commands.
  • An attacker can create an account even when user registration is disabled because of an exposed, undocumented registration action in GiveWP.
  • Exploitation requires an older donation form that lacks formBuilderSettings, which may occur after a site upgrade or the import of old forms.
  • Version 4.16.7.2 fixes the vulnerability and removes previously stored serialized object payloads from affected databases.
  • GiveWP’s registration mechanism still does not honor WordPress’s user-registration setting, but after the update it is no longer exploitable for code execution.

FAQ

Which GiveWP versions are affected?

Versions through 4.16.7.1 are affected, and versions 4.16.6 through 4.16.7.1 remain exploitable when an older donation form lacking formBuilderSettings is present.

Which version fixes the vulnerability?

Version 4.16.7.2, released on August 27, 2026, fixes the flaw and removes previously stored serialized payloads from affected databases.

Does exploitation require an account?

The attack’s initial stage requires an account on the site, but an exposed registration action in GiveWP may allow an account to be created even when registration is disabled in WordPress settings.

Is this vulnerability connected to the previous Pi-hole compromise incident?

The source does not establish a direct connection between the previous Pi-hole compromise campaign and CVE-2026-82222.

In the same category

You may also like

View all news